35 lines
800 B
Nix
35 lines
800 B
Nix
{
|
|
description = "Nixos config flake";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
|
|
|
|
# Hyprland WM
|
|
hyprland.url = "github:hyprwm/Hyprland";
|
|
|
|
# Neovim Package Manager
|
|
nvf = {
|
|
url = "github:notashelf/nvf";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
|
|
home-manager = {
|
|
url = "github:nix-community/home-manager";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
};
|
|
|
|
outputs = { self, nixpkgs, ... }@inputs: {
|
|
nixosConfigurations = {
|
|
# This should correspond to the hostname of the machine
|
|
t0urn3s0l = nixpkgs.lib.nixosSystem {
|
|
specialArgs = {inherit inputs;};
|
|
|
|
modules = [
|
|
./hosts/t0urn3s0l/configuration.nix
|
|
inputs.home-manager.nixosModules.default
|
|
];
|
|
};
|
|
};
|
|
};
|
|
}
|