80 lines
3 KiB
Nix
80 lines
3 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{ config, lib, pkgs, modulesPath, ... }:
|
||
|
||
{
|
||
imports =
|
||
[ (modulesPath + "/installer/scan/not-detected.nix")
|
||
];
|
||
|
||
boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "nvme" "usb_storage" "usbhid" "sd_mod" ];
|
||
boot.initrd.kernelModules = [ ];
|
||
boot.kernelModules = [ "kvm-intel" ];
|
||
boot.extraModulePackages = [ ];
|
||
|
||
fileSystems."/" =
|
||
{ device = "/dev/disk/by-uuid/57749360-7043-4fc8-bf3c-b32f19637286";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
fileSystems."/boot" =
|
||
{ device = "/dev/disk/by-uuid/D962-22E9";
|
||
fsType = "vfat";
|
||
options = [ "fmask=0077" "dmask=0077" ];
|
||
};
|
||
|
||
fileSystems."/home/zuma" =
|
||
{ device = "/dev/disk/by-uuid/f2e59848-b5d2-4b10-a2de-e6ee14a62465";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
swapDevices =
|
||
[ { device = "/dev/disk/by-uuid/378cddd8-07d7-437e-9d1d-3c9bc91e5330"; }
|
||
];
|
||
|
||
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
|
||
# (the default) this is the recommended approach. When using systemd-networkd it's
|
||
# still possible to use this option, but it's recommended to use it in conjunction
|
||
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
|
||
networking.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.enp7s0.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.wlp0s20f3.useDHCP = lib.mkDefault true;
|
||
|
||
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
|
||
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
||
|
||
hardware.graphics = {
|
||
enable = true;
|
||
};
|
||
services.xserver.videoDrivers = ["nvidia"];
|
||
hardware.nvidia = {
|
||
# Modesetting is required.
|
||
modesetting.enable = true;
|
||
|
||
# Nvidia power management. Experimental, and can cause sleep/suspend to fail.
|
||
# Enable this if you have graphical corruption issues or application crashes after waking
|
||
# up from sleep. This fixes it by saving the entire VRAM memory to /tmp/ instead
|
||
# of just the bare essentials.
|
||
powerManagement.enable = false;
|
||
|
||
# Fine-grained power management. Turns off GPU when not in use.
|
||
# Experimental and only works on modern Nvidia GPUs (Turing or newer).
|
||
powerManagement.finegrained = false;
|
||
|
||
# Use the NVidia open source kernel module (not to be confused with the
|
||
# independent third-party "nouveau" open source driver).
|
||
# Support is limited to the Turing and later architectures. Full list of
|
||
# supported GPUs is at:
|
||
# https://github.com/NVIDIA/open-gpu-kernel-modules#compatible-gpus
|
||
# Only available from driver 515.43.04+
|
||
open = false;
|
||
|
||
# Enable the Nvidia settings menu,
|
||
# accessible via `nvidia-settings`.
|
||
nvidiaSettings = true;
|
||
|
||
# Optionally, you may need to select the appropriate driver version for your specific GPU.
|
||
package = config.boot.kernelPackages.nvidiaPackages.stable;
|
||
};
|
||
}
|